DHCP-Config for Alcatel 8012 & 8118

IP and Voice over IP
Post Reply
linuxdhcpman
Member
Posts: 3
Joined: 19 Jul 2017 05:43

DHCP-Config for Alcatel 8012 & 8118

Post by linuxdhcpman » 19 Jul 2017 06:32

Hello, i have a big little problem with my dhcp.conf. The server is the ISC-server and the OS is CentOS 7. I googled the whole morning for the "option vendor-encapsulated-options", for the 8118 IP-phone, but found nothing. Also i'm not sure if my config is right... The problem is that the phone don't take a IP from his Pool.

Code: Select all

#8012
class "Alcatel-Lucent_IPTouch" {
match if option vendor-class-identifier = "alcatel.noe.0";
}

#8118
class "Alcatel-WLAN-Telefone" {
match if option vendor-class-identifier = "alcatel.mipt.1";
}

option option-150 code 150 = ip-address;

Code: Select all

     #Subnet 7 
        subnet 192.168.117.0            netmask 255.255.255.0 {

        range dynamic-bootp             192.168.117.121 192.168.117.254;
        option routers                  	     	192.168.117.9;
        option domain-name-servers      192.168.141.69, 192.168.141.70, 192.168.141.171;
        option broadcast-address        192.168.117.255;
        default-lease-time              604800;
        authoritative;
        option option-150        	       192.168.99.50;
        next-server            		         192.168.99.50;

        pool {

        allow members of "Alcatel-Lucent_IPTouch";
        range dynamic-bootp             192.168.117.100 192.168.117.110;
        next-server                     192.168.99.50;

        if exists vendor-encapsulated-options {
        ddns-updates off;
        option vendor-encapsulated-options 40:04:c0:a8:17:3d:41:04:c0:a8:17:05;
        max-lease-time                  604860;
        min-lease-time                  604800;
        option option-150               192.168.99.50;
}
}

        pool {

        allow members of "Alcatel-WLAN-Telefone";
        range dynamic-bootp             192.168.117.111 192.168.117.120;
        next-server                     192.168.99.50;

        if exists vendor-encapsulated-options {
        ddns-updates off;
       #option vendor-encapsulated-options 40:04:c0:a8:17:3d:41:04:c0:a8:17:05;
        max-lease-time                  604860;
        min-lease-time                  604800;
        option option-150               192.168.99.50;

linuxdhcpman
Member
Posts: 3
Joined: 19 Jul 2017 05:43

Re: DHCP-Config for Alcatel 8012 & 8118

Post by linuxdhcpman » 02 Aug 2017 09:50

Hello? I have no idea, what i have to do to fix this problem...

This is the actual code

class "8018" {
match if option vendor-class-identifier = "alcatel.noe.0";
option vendor-encapsulated-options "alcatel.a4400.0";
option tftp-server-name "192.168.99.50";
}

pool {

allow members of "8018";
range 192.168.117.100 192.168.117.110;
next-server 192.168.99.50;
option option-43 192.168.99.50;
option option-128 192.168.99.50;
option option-150 192.168.99.50;
}

mgoegel
Member
Posts: 247
Joined: 12 Feb 2007 12:18
Location: Germany

Re: DHCP-Config for Alcatel 8012 & 8118

Post by mgoegel » 05 Aug 2017 02:29

You don't have other dhcp servers in this network?
Do you have other ranges in your config, or is this the whole config?
If others are present, you have to deny this class in them and deny all others in this one.
Other thing I recently found out, that it worked, when I changed the'if' condition to
... if ( option ... );
I'm not sure, if this is correct nor needed. Should inform about the syntax some time... [emoji38]


Gesendet von iPad mit Tapatalk

mgoegel
Member
Posts: 247
Joined: 12 Feb 2007 12:18
Location: Germany

Re: DHCP-Config for Alcatel 8012 & 8118

Post by mgoegel » 05 Aug 2017 02:31

I have similar config on my server as home. When I return today, then I'll take a look at it.

Mario


Gesendet von iPad mit Tapatalk

mgoegel
Member
Posts: 247
Joined: 12 Feb 2007 12:18
Location: Germany

Re: DHCP-Config for Alcatel 8012 & 8118

Post by mgoegel » 06 Aug 2017 12:01

Hi,

this is how my current config for MyIC phones looks.
You just need to change the VCI, then it should work.

Code: Select all

class "ictouch8082" {
    match if substring (option vendor-class-identifier, 0, 17) = "alcatel.ictouch.0";
    option vendor-encapsulated-options "alcatel.a4400.0";
    log (debug, concat("Matched alcatel.ictouch.0 for ", binary-to-ascii (16,8, ":", hardware)));
}

[...]

subnet x.x.x.x netmask y.y.y.y {
[...]
  pool {
    range 10.33.11.113 10.33.11.116;
    next-server 10.120.1.156;
    allow members of "ictouch8082";
    option domain-name-servers 10.1.1.20;
  }
[...]
}
Regards Mario

linuxdhcpman
Member
Posts: 3
Joined: 19 Jul 2017 05:43

Re: DHCP-Config for Alcatel 8012 & 8118

Post by linuxdhcpman » 09 Aug 2017 01:47

Hallo Mario,
it tried your config but the phone is still not booting. The problem is the authentification. Because of the missing connection, the cant connect to the TFTP-Server... Have you a another idea for the authentification?

Something like this:

match if substring (option vendor-class-identifier, 0, 17) = "alcatel.ictouch.0";

thanks a lot for your help!!!

PS: Sind Sie aus Deutschland? Wenn ja können Sie auf Deutsch antworten. :)

User avatar
tgn
Member
Posts: 801
Joined: 30 Dec 2009 17:59
Location: Germany

Re: DHCP-Config for Alcatel 8012 & 8118

Post by tgn » 09 Aug 2017 16:06

Hello linuxdhcpman,

which phone doesn't connect. 8012, 8118 or both of them?
Does the phone sets with the faulty dhcp have a display message with an error message?

Regarding your request to post in german -> I'm German too, but his forum is in english language and posting in other languages is not welcome. You can stay in contact (even in german language) with PM. But post you solution here when you'll find it, please.

thanks and regards...

@Mario tyvm for sharing your dhcp-config.


--- back to basics... focus your eyes to the essential things... ---
--- back to basics... focus your eyes to the essential things... ---

Post Reply

Return to “IP / VoIP”