Phone Book overflow on LDAP server

Post Reply
alhmami
Member
Posts: 16
Joined: 08 Oct 2013 01:17

Phone Book overflow on LDAP server

Post by alhmami » 22 Nov 2017 02:49

Hi All,
I'm trying to integrated OXE with LDAP active directory but it's not working her what i did:

1:
Node Number (reserved) : 4
Instance (reserved) : 1
Instance (reserved) : 1
System Option + Phone Book overflow on LDAP server

Phone Book overflow on LDAP server + True

2:
Node Number (reserved) : 4
Instance (reserved) : 1
Instance (reserved) : 1
System Option + LDAP Direct Access

LDAP Direct Access + True

3:
Node Number (reserved) : 4
Instance (reserved) : 1
LDAP Phone book : 1

Server Name : 10.140.8.2
Server Port Number : 636
User Identification : ot-alcatel
Directory Root Entry : ou=ot-USERS,dc=alcatel

User Password : **********
Confirm : **********
Did I forgot something or not I tried to run client_ldap but no result

(4)xb000004> client_ldap

Entity of set
1

0 => Exit
1 => Search by name
2 => Search by initial
3 => Search by name and first name
1
Request Name ...
telecom
Request 7 telecom
Result reply_count 0
(4)xb000004>


any advice?

User avatar
oldboy
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 746
Joined: 25 Aug 2005 18:24

Re: Phone Book overflow on LDAP server

Post by oldboy » 22 Nov 2017 03:13

you need to turn it on in Entitiy, i believe so it is linked to something

Always good to have a ldap browser to check your correct root entrys

http://www.ldapbrowser.com/info_softerr ... rowser.htm
"Be aware ask a stupid question without at least trying to find the answer first you may get a stupid answer....."

alhmami
Member
Posts: 16
Joined: 08 Oct 2013 01:17

Re: Phone Book overflow on LDAP server

Post by alhmami » 22 Nov 2017 03:36

Hi oldboy,
Sorry I forgot to mention early that I turn it on in the entity please check

Node Number (reserved) : 4
Entity Number : 1

Name : ENTITY_1
UTF-8 Name : -----------
Attendant Group Manager : 1
Priority + NO
Emergency call to attd + NO
Traffic Overflow + Disallowed
.
.
.
.
Voice Guides

Waiting Guide : 2
Attendant Waiting Guide : 110

Overflow Timer : 0
Company Call Number : --------
Centralized Centrex Serv. + False
Overflow LDAP Phone Book : 1



and the root entrys I got it from LDAP administrator

User avatar
oldboy
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 746
Joined: 25 Aug 2005 18:24

Re: Phone Book overflow on LDAP server

Post by oldboy » 22 Nov 2017 06:02

I would still use a ldap browser to confirm those setting including the password
"Be aware ask a stupid question without at least trying to find the answer first you may get a stupid answer....."

alhmami
Member
Posts: 16
Joined: 08 Oct 2013 01:17

Re: Phone Book overflow on LDAP server

Post by alhmami » 28 Nov 2017 13:27

Hi oldboy,
Sorry for the delay I was doing some test for this and I capture trace from OXE, and I upload it to this website https://ask.wireshark.org/question/617/ ... his-trace/
They told me my server is trying to use plaintext LDAP on port 636/tcp
So can we use port 636 in overflow ladp or we have to use 389 port
this the trace https://drive.google.com/file/d/1IWsedv ... sp=sharing
Thanks in advance
Last edited by alhmami on 29 Nov 2017 01:43, edited 1 time in total.

alhmami
Member
Posts: 16
Joined: 08 Oct 2013 01:17

Re: Phone Book overflow on LDAP server

Post by alhmami » 28 Nov 2017 13:32

oldboy wrote:
22 Nov 2017 06:02
I would still use a ldap browser to confirm those setting including the password
I checked the software (ldap browser) and the username and password are correct and I can see the directory

User avatar
tot3nkopf
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 4025
Joined: 02 Feb 2006 10:41
Location: Germany & Romania
Contact:

Re: Phone Book overflow on LDAP server

Post by tot3nkopf » 29 Nov 2017 09:16

Check maybe firewall between PBX and LDAP server...

Post Reply

Return to “Phone Book”