Ringback Tone Problem on SIP Ext GW Incoming Call

User avatar
giovanni.attolini
Member
Posts: 271
Joined: 16 Apr 2009 13:44
Location: Veranopolis-RS-BRAZIL
Contact:

Ringback Tone Problem on SIP Ext GW Incoming Call

Post by giovanni.attolini » 05 Sep 2017 12:44

Hello world!

I have a problem here with ringback tone on OXE.


Scenario:
                            /--PCM->  OPERATOR
                           /
ASTERISK  <-SIP->  OXE  <--
                           \
    ˄               ˄       \--T2-->  OPERATOR 2
    |               |
    |               |
    ˅               ˅

SIP PHONE        IP PHONE


Situation:
Call from IP PHONE to OPERATOR 1 (PCM), RBT ok
Call from IP PHONE to OPERATOR 2 (T2), RBT ok
Call from SIP PHONE to OPERATOR 1 (PCM), RBT ok
Call from SIP PHONE to OPERATOR 2 (T2), RBT nok

So, only calls from SIP PHONE to OPERATOR 2 using T2 that you see this problem. I made a trace and the problem is that OXE doesn't send RTP packets until the called number answer the call, when you make a call you start hearing the destination speaker talking directly and the call remains mute until the answer.

Any sugestion?

Thanks for all.
Giovanni A. Attolini
https://www.facebook.com/gio.atto

"When you make a stupid question, wait for a stupid answer!"

User avatar
cavagnaro
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 7004
Joined: 14 Sep 2005 19:45
Location: Brasil, Porto Alegre
Contact:

Re: Ringback Tone Problem on SIP Ext GW Incoming Call

Post by cavagnaro » 05 Sep 2017 14:35

Sounds like an early media issue...which OXE version?

Enviado de meu E6633 usando Tapatalk

Ignorance is not the problem, the problem is the one who doesn't want to learn

OTUC/ICS ACFE/ACSE R3.0/4.0/5.0/6.0
Certified Genesys CIV 8.5
Certified Genesys Troubleshooting 8.5
Certified Genesys BEP 8.x
Genesys Developer

User avatar
giovanni.attolini
Member
Posts: 271
Joined: 16 Apr 2009 13:44
Location: Veranopolis-RS-BRAZIL
Contact:

Re: Ringback Tone Problem on SIP Ext GW Incoming Call

Post by giovanni.attolini » 05 Sep 2017 15:06

Yeah!

CPU type : cpu82
Linux version : 76.20

Delivery software version : j2.603 ;
Patch version : 38 ;

MAO software version : J2.603.38 ;
Software Version Name : R10.1.1 ;
System Country : BRAZIL (35);
System for Large Config : no;
Giovanni A. Attolini
https://www.facebook.com/gio.atto

"When you make a stupid question, wait for a stupid answer!"

User avatar
giovanni.attolini
Member
Posts: 271
Joined: 16 Apr 2009 13:44
Location: Veranopolis-RS-BRAZIL
Contact:

Re: Ringback Tone Problem on SIP Ext GW Incoming Call

Post by giovanni.attolini » 05 Sep 2017 15:40

Strange that occurs using T2 and not using PCM/R2.
Giovanni A. Attolini
https://www.facebook.com/gio.atto

"When you make a stupid question, wait for a stupid answer!"

User avatar
enio.eltz
Senior Member
Posts: 1039
Joined: 28 Jul 2009 09:48
Location: Taquara - RS - Brazil

Re: Ringback Tone Problem on SIP Ext GW Incoming Call

Post by enio.eltz » 06 Sep 2017 07:41

Hi

Could you post Wireshark traces of calls from SIP Phone to PCM R2 and SIP Phone to T2 capturing CS?
Did you check the trace when you have RBT with PCM R2? What does the OXE send? 180 or 183?

Best regards.
Enio Eltz Filho
ACFE OXE R12/R11/R10
ACFE OXO CONNECT R2
ACFE OXO R10/R9

User avatar
cavagnaro
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 7004
Joined: 14 Sep 2005 19:45
Location: Brasil, Porto Alegre
Contact:

Re: Ringback Tone Problem on SIP Ext GW Incoming Call

Post by cavagnaro » 06 Sep 2017 07:43

Can you post the T3 logs as well? Could be a bad message from your operator...

Enviado de meu E6633 usando Tapatalk

Ignorance is not the problem, the problem is the one who doesn't want to learn

OTUC/ICS ACFE/ACSE R3.0/4.0/5.0/6.0
Certified Genesys CIV 8.5
Certified Genesys Troubleshooting 8.5
Certified Genesys BEP 8.x
Genesys Developer

User avatar
giovanni.attolini
Member
Posts: 271
Joined: 16 Apr 2009 13:44
Location: Veranopolis-RS-BRAZIL
Contact:

Re: Ringback Tone Problem on SIP Ext GW Incoming Call

Post by giovanni.attolini » 11 Sep 2017 08:16

Attached are traces from CS: T3 messages and SIP messages.
You do not have the required permissions to view the files attached to this post.
Giovanni A. Attolini
https://www.facebook.com/gio.atto

"When you make a stupid question, wait for a stupid answer!"

haroun
Member
Posts: 899
Joined: 29 Mar 2010 11:09

Re: Ringback Tone Problem on SIP Ext GW Incoming Call

Post by haroun » 25 Sep 2017 19:33

deep trace
tuner km
tuner ctr
trc i
tuner clear-traces
tuner all=off
actdbg all=off
tuner +at +tr +s +cpu +cpl hybrid=on
actdbg sip=on fct=on isdn=on abcf=on rtp=on
actdbg cnx=on voip=on
mtracer -ag -1 /tmpd/desinationfile -f 99 -s 4000000 -d&

User avatar
giovanni.attolini
Member
Posts: 271
Joined: 16 Apr 2009 13:44
Location: Veranopolis-RS-BRAZIL
Contact:

Re: Ringback Tone Problem on SIP Ext GW Incoming Call

Post by giovanni.attolini » 25 Sep 2017 21:10

haroun wrote:
25 Sep 2017 19:33
deep trace
tuner km
tuner ctr
trc i
tuner clear-traces
tuner all=off
actdbg all=off
tuner +at +tr +s +cpu +cpl hybrid=on
actdbg sip=on fct=on isdn=on abcf=on rtp=on
actdbg cnx=on voip=on
mtracer -ag -1 /tmpd/desinationfile -f 99 -s 4000000 -d&
Ok, I will provide!
Giovanni A. Attolini
https://www.facebook.com/gio.atto

"When you make a stupid question, wait for a stupid answer!"

User avatar
giovanni.attolini
Member
Posts: 271
Joined: 16 Apr 2009 13:44
Location: Veranopolis-RS-BRAZIL
Contact:

Re: Ringback Tone Problem on SIP Ext GW Incoming Call

Post by giovanni.attolini » 26 Sep 2017 12:40

Trace attached.

Sorry but I don't know where it ends.
You do not have the required permissions to view the files attached to this post.
Giovanni A. Attolini
https://www.facebook.com/gio.atto

"When you make a stupid question, wait for a stupid answer!"

Post Reply

Return to “SIP”