Time Zone Problem with Onmivista

Post Reply
cayassir
Member
Posts: 18
Joined: 21 Aug 2008 12:07

Time Zone Problem with Onmivista

Post by cayassir » 22 Aug 2008 09:35

Hi,

Does anyone knows where the Omnivista 4760 gets the time?

In my country (Venezuela) we changed the time zone from -4:00GMT to -4:30GMT. I changed the time zone in the computer (Win XP) where Omnivista Server is installed. Now the time that shows the OmniVista is all wrong 5:30 hours ahead but the computer shows the rigth time.

I will appreciate some help

AquaFresh
Member
Posts: 2
Joined: 10 Sep 2008 06:31

Re: Time Zone Problem with Onmivista

Post by AquaFresh » 10 Sep 2008 06:37

I looks like OV is using UTC time, we had the same issues, installing the latest release (we use OV2500) 3.4.1 solved it, it uses the server system.

corwin
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 167
Joined: 28 Dec 2008 04:20

Re: Time Zone Problem with Onmivista: Venezuela

Post by corwin » 28 Jan 2009 02:01

This issue has been reported a few weeks ago
this is due to JRE version

Java read timezone system option and then compute the right time
there is a complex fix for this issue
first you will have to update the timezone module of java, so the timezone for venezuela will be present

then there will be a second issue that JRE mix to Timezone when reading system information
the only workaround will be to force in runnmc.bat the usage of Venezuela TimeZone
I strongly suggest you call the hot line for the workaround

anyway here the SUNE ONE URL for the JRE fix
If the JRE Version is less than 6.4 (JRE 1.6.0_4) and in your PC if you have seperate timezone for caracus (caracas). GMT -4.30 then TZupdater tool has to be installed.

You can download it from below link.
http://java.sun.com/javase/tzupdater_README.html



and here the change in runnmc.bat to apply (add option :-Duser.timezone=America/Caracas)

echo Launch : {C:\Program Files\Java\jre1.6.0_03\bin\javaw.exe" -Xmx512m -DJNORESPONSETIMEOUT=300000 -DJUSEDMEM=512 -Xincgc -classpath %CLASSPATH%} ...

START /B "" "C:\Program Files\Java\jre1.6.0_03\bin\javaw.exe" -Duser.timezone=America/Caracas -Xmx512m -DJNORESPONSETIMEOUT=300000 -DJUSEDMEM=512 -Xincgc -classpath %CLASSPATH%
if "%1"=="--debug" goto ExitBatch


this will be definitively fixed when 4760 will change the JRE version to one that incorporate the complet fix

Post Reply

Return to “OmniVista 4760”