No statistic data in SoftPanel manager

User avatar
whistler
Member
Posts: 16
Joined: 13 May 2010 05:42
Location: Russia

No statistic data in SoftPanel manager

Post by whistler » 10 Apr 2012 06:40

hi.
little bit confused about absence information in realtime data > statistic of SoftPanel 5.9.0
RTI seems working, log data:
2012-04-10 16:21:53 : registration data to CCS...
2012-04-10 16:21:53 : Getting objects Pilot
2012-04-10 16:21:53 : monitoring Pilot1
2012-04-10 16:21:53 : Getting objects WaitingQueue
2012-04-10 16:21:53 : monitoring WQ1
2012-04-10 16:21:53 : Getting objects ProcessingGroupAgent
2012-04-10 16:21:53 : monitoring PG1
2012-04-10 16:21:53 : Getting objects ProcessingGroupOther
2012-04-10 16:21:53 : Pilot1 subscribed
2012-04-10 16:21:53 : statistics subsribed : ,State,NbOfRunningCalls,ServiceLevel,Efficiency,NbOfWaitingCalls,NbOfRingingACDCalls,NbOfMutualAidCalls,NbOfDissuadedCalls,NbOfCallsInConversation,NbOfCallsInGeneralForwarding,NbOfCallsInRemotePG,IncomingTraffic,AverageWaitingTime
2012-04-10 16:21:53 : WQ1 subscribed
2012-04-10 16:21:53 : statistics subsribed : ,Type,State,NbOfAgentsInDistribution,IncomingTraffic,OutgoingTraffic,NbOfWaitingCalls,CurrentWaitingTime,FillingRate,ExpectedWaitingTime,LongestWaitingTimeInList
2012-04-10 16:21:53 : PG1 subscribed
2012-04-10 16:21:53 : statistics subsribed : ,Type,State,NbOfWidthdrawnAgents,NbOfAgentsInPrivateCall,NbOfAgentsInACDCall,NbOfAgentsInACDRinging,NbOfAgentsInACDConv,NbOfAgentsInWrapupAndTransaction,NbOfAgentsInPause,NbOfBusyAgents,NbOfLoggedOnAgents,NbOfFreeAgents,NbOfIdleAgents,NbOfLoggedOnAndNotWithdrawnAgents,IncomingTraffic,ConsolidatedQueuesWaitingTime,ConsolidatedQueuesNbOfWaitingCalls,ConsolidatedQueuesEWT
2012-04-10 16:21:53 : connected to CCS successfully

but nothing in softpanel. this is my first setup of manager, please show me way for next step. Maybe something wrong in RTIconnector.ini?


my RTIconnector:
[main]
; --- Maximum 30 filters
;
; --- Filter samples
; * = all objects
; A* = all objects name beginning by A
; A?B = all object name AxB, ...

; --- Objet type to monitor = FilterNameObjectType
; FilterNameObjectType = Pilot, WaitingQueue, ProcessingGroupAgent, ProcessingGroupOther, Agent
FilterNameObjectType = Pilot, WaitingQueue, ProcessingGroupAgent, ProcessingGroupOther

; --- CCD object name to monitor
; FilterRelatedObjectName = *NomAGENT_SK2*, VAYSSAC*, LEBLEU*, TOTO*
; To monitor PF : 2_GT2 et 2_GT1 => FilterRelatedObjectName = 2_GT*
;;FilterRelatedObjectName = *
FilterRelatedObjectName = Pilot1,WQ1,PG1

; --- Names of the counters to monitor = FilterKeyValue
; FilterKeyValue = !WithdrawalsTotalDuration
; FilterKeyValue = AssociatedSet*, Withdraw*, PhoneState*
; FilterKeyValue = PhoneState*
FilterKeyValue = *


; --- Cacher les objets et supprimer les traitements de trace, par dйfaut True
HideMode = False

#----------------------------------
# WBM configuration file
# Created while installing version 1.10.0.0
#----------------------------------
WBMHost=localhost
WBMPortNum=61668

#--Time between CCS connection and data subscription --------------
dataSubscriptionTimer=60


its lab station now

krzysioD
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 1153
Joined: 30 Aug 2006 13:43
Location: Europe, Poland

Re: No statistic data in SoftPanel manager

Post by krzysioD » 11 Apr 2012 09:58

Wait one minute (60 secs timeout). Then, well, for 1st run, wait some more time, and search under:
http://your@ip:9060/wbm/rtiStatList.html
if it does not help, try this:
FilterRelatedObjectName = *
in rticonnector
should work iirc.
What SPS version?
Please note that at no time I will provide you with OXE/4400 nor AOS releases.
Note that it's our private time, that we spent to help you, so please don't expect complete solution for your problem.
You will need to do homework by your self.

User avatar
whistler
Member
Posts: 16
Joined: 13 May 2010 05:42
Location: Russia

Re: No statistic data in SoftPanel manager

Post by whistler » 11 Apr 2012 12:14

hi!
i do my tests on lab PBX b PC, everything is on laptop - CCS, RTI, SPS. versions^ PBX j1.410.40 CCS 10.0.9.2 RTI 1.8.0 SPS 5.7.0 i have license for RTI, ccs.ini put on windows dir... CCS didnt start manually, mark on "connect o start-up" set...
checked one more time - nothing on rtistatlist screen... i believe where should be list of available data to construct view vidgets... nothing now "no statistic found"

any more suggestions? i can try different PBX software, but on customer site we have r10
Last edited by whistler on 11 Apr 2012 12:20, edited 1 time in total.

krzysioD
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 1153
Joined: 30 Aug 2006 13:43
Location: Europe, Poland

Re: No statistic data in SoftPanel manager

Post by krzysioD » 11 Apr 2012 12:19

have you put an asterisk mark in rticonnector.ini as i suggested?
Please note that at no time I will provide you with OXE/4400 nor AOS releases.
Note that it's our private time, that we spent to help you, so please don't expect complete solution for your problem.
You will need to do homework by your self.

User avatar
whistler
Member
Posts: 16
Joined: 13 May 2010 05:42
Location: Russia

Re: No statistic data in SoftPanel manager

Post by whistler » 11 Apr 2012 12:22

Yes. it even present in default rticonnector.ini file.... as i can see in log object registered from PBX, staistic subscribed...

krzysioD
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 1153
Joined: 30 Aug 2006 13:43
Location: Europe, Poland

Re: No statistic data in SoftPanel manager

Post by krzysioD » 11 Apr 2012 12:29

So - wait - for the very 1st time - it takes a lot of a while to see 1st results.
And try to see a log file under rticonnector, then log any agent into any pg, take a acd call (make agent busy) - it should make a line into rti connector log file.
if it does make entry in log file, you need to have some more patience...
Please note that at no time I will provide you with OXE/4400 nor AOS releases.
Note that it's our private time, that we spent to help you, so please don't expect complete solution for your problem.
You will need to do homework by your self.

User avatar
whistler
Member
Posts: 16
Joined: 13 May 2010 05:42
Location: Russia

Re: No statistic data in SoftPanel manager

Post by whistler » 11 Apr 2012 12:49

2012-04-11 22:46:13 : Disconnected from CCS
2012-04-11 22:46:30 : Soft panel manager disconnected no ping received from server
2012-04-11 22:46:30 : Soft panel manager is not connected
2012-04-11 22:46:30 : Disconnecting from soft panel manager
2012-04-11 22:46:30 : Soft panel manager is disconnected
2012-04-11 22:46:30 : disconnect from CCS in progress...
2012-04-11 22:46:30 : Disconnected from CCS
2012-04-11 22:46:32 : Connected to WBM
2012-04-11 22:46:33 : Soft panel manager connected, subscribing to RTI keepalive
2012-04-11 22:46:36 : Retrying to connect to CCS........
2012-04-11 22:46:39 : connection to CCS in progress...
2012-04-11 22:46:44 : registration data to CCS...
2012-04-11 22:46:44 : Getting objects Pilot
2012-04-11 22:46:44 : monitoring Pilot1
2012-04-11 22:46:44 : Getting objects WaitingQueue
2012-04-11 22:46:44 : monitoring WQ1
2012-04-11 22:46:44 : Getting objects ProcessingGroupAgent
2012-04-11 22:46:44 : monitoring PG1
2012-04-11 22:46:44 : Getting objects Agent
2012-04-11 22:46:44 : monitoring Agent 250000
2012-04-11 22:46:45 : Pilot1 subscribed
2012-04-11 22:46:45 : statistics subsribed :
2012-04-11 22:46:45 : WQ1 subscribed
2012-04-11 22:46:45 : statistics subsribed :
2012-04-11 22:46:45 : PG1 subscribed
2012-04-11 22:46:45 : statistics subsribed :
2012-04-11 22:46:45 : Agent 250000 subscribed
2012-04-11 22:46:45 : statistics subsribed : ,Name,Number,ServiceState,PhoneState,StateDuration,ComDuration,LogonDuration,WithdrawalsTotalDuration,PrivateCallsTotalDuration
2012-04-11 22:46:45 : connected to CCS successfully



this is last strings from rti log after what i make call - nothing in log. i really call via pilot 250001, voice guides etc. is working.

everything what happens with agent should be logged? i cant imagine size of log in real callcenter environment

User avatar
whistler
Member
Posts: 16
Joined: 13 May 2010 05:42
Location: Russia

Re: No statistic data in SoftPanel manager

Post by whistler » 11 Apr 2012 13:13

ok. tomorrow i'll try some investigations with adm_acd tool... probably i have to trace what happens on PBX side... why i didnt have rti events

its late here now, tomorrow i'll try to give more info from PBX... and will take vargan from home for dance around SPS

User avatar
whistler
Member
Posts: 16
Joined: 13 May 2010 05:42
Location: Russia

Re: No statistic data in SoftPanel manager

Post by whistler » 12 Apr 2012 07:08

ok. SPS up and flying now. Problem was with CCS, it's not written in SPS documentation in check-list chapter, but you should check option "CCS get real-time information then no supervisor logged-in" during CCS installation. without it RTI can't access data from CCS because CCS is not connected to AFE PBX... it visible in adm_acd tool as no c0nnected WBI interface

ross_01
Member
Posts: 12
Joined: 20 Aug 2008 05:46

Re: No statistic data in SoftPanel manager

Post by ross_01 » 26 Sep 2012 17:28

Hi ALU Hackers :-)

i'm getting crazy by searching "Why is RTI Server not Connecting"

i have installed the SoftPanelManager (Standart Edition) 5.12.4.0 running on Win2008R2 SP1 x64
before i installed CCS 10.00.90.01 + the RTI Server which is included in SPM 5.12.4....

CCS is running (auto connect to OXE)
Lizenz in OXE is fine:
Start_date: 1348652388 Wed Sep 26 11:39:48 2012
Version: 8.1.90, Args:
15
write: lgw= 16, nbe= 16
List of software package used
Package id=78 CCD Ticket current=0 max=0
Package id=77 CCS Mono current=0 max=1
Package id=102 CCS Multi current=0 max=0
Package id=112 CCS Light current=0 max=0
Package id=103 WBI Licence current=0 max=1
Package id=94 WFP Licence current=0 max=0
Package id=115 CCA Licence current=0 max=0
Package id=157 CCA Nomadic current=0 max=0
Package id=161 CCO current=0 max=0
Package id=162 CCO Predictif current=0 max=0
Package id=167 ACR Database current=0 max=0
Package id=160 Email Capability current=0 max=0
Package id=125 Web Capability current=0 max=0
Package id=189 CCA SDK Capabili current=0 max=0
Package id=311 Networking ACR current=0 max=0
Package id=312 Outbound scripti current=0 max=0

RTI_LOG show this bloody error and i dont know why ?
2012-09-26 23:05:19 : read InitFile in progress...C:\Program Files (x86)\Alcatel-Lucent\RTIConnector\RTIConnector.ini
2012-09-26 23:05:19 : -----------init parameters rticonnector version 1.11.0-----------------
2012-09-26 23:05:19 : Object Type Filter 0 >Pilot<
2012-09-26 23:05:19 : Object Type Filter 1 > WaitingQueue<
2012-09-26 23:05:19 : Object Type Filter 2 > ProcessingGroupAgent<
2012-09-26 23:05:19 : Object Type Filter 3 > ProcessingGroupOther<
2012-09-26 23:05:19 : Object Name Filter 0 >*<
2012-09-26 23:05:19 : key filter 0 >*<
2012-09-26 23:05:19 : WBMHost : localhost
2012-09-26 23:05:19 : WBMPortNum : 61668
2012-09-26 23:05:19 : dataSubscriptionTimer : 60
2012-09-26 23:05:19 : adding statistic names used to get configuration and Agent object type
2012-09-26 23:05:20 : Socket Error : [10061]:Connection is forcefully rejected... retrying to connect to WBM...
2012-09-26 23:05:20 : Disconnecting from soft panel manager
2012-09-26 23:05:20 : Soft panel manager is disconnected
2012-09-26 23:05:20 : disconnect from CCS in progress...
2012-09-26 23:05:20 : Disconnected from CCS
2012-09-26 23:05:41 : Socket Error : [10061]:Connection is forcefully rejected... retrying to connect to WBM...
2012-09-26 23:05:41 : Disconnecting from soft panel manager
2012-09-26 23:05:41 : Soft panel manager is disconnected
2012-09-26 23:05:41 : disconnect from CCS in progress...
2012-09-26 23:05:41 : Disconnected from CCS
2012-09-26 23:06:01 : Socket Error : [10061]:Connection is forcefully rejected... retrying to connect to WBM...
2012-09-26 23:06:01 : Disconnecting from soft panel manager
2012-09-26 23:06:01 : Soft panel manager is disconnected
2012-09-26 23:06:01 : disconnect from CCS in progress...
2012-09-26 23:06:01 : Disconnected from CCS
2012-09-26 23:06:19 : Soft panel manager disconnected no ping received from server
2012-09-26 23:06:19 : Soft panel manager is not connected
2012-09-26 23:06:19 : Disconnecting from soft panel manager
2012-09-26 23:06:19 : Soft panel manager is disconnected
2012-09-26 23:06:19 : disconnect from CCS in progress...
2012-09-26 23:06:19 : Disconnected from CCS
2012-09-26 23:06:21 : Socket Error : [10061]:Connection is forcefully rejected... retrying to connect to WBM...
2012-09-26 23:06:21 : Disconnecting from soft panel manager
2012-09-26 23:06:21 : Soft panel manager is disconnected
2012-09-26 23:06:21 : disconnect from CCS in progress...

In SPM doc is written, that Softpanel will create automaticaly following folder:
C:\Windows\SysWOW64\config\systemprofile\AppData\Local\Alcatel\CCSupervisor (were ccs.ini should be located)
at my lab it did not... i created that folder by myself! (how was it it your installations? )

Big THX for supporting me
ross

Post Reply

Return to “Call Center SoftPanel (ALU ProServices)”