FlexLM error

Post Reply
BlueFox
Member
Posts: 20
Joined: 30 May 2008 18:09

FlexLM error

Post by BlueFox » 30 Oct 2012 07:12

Hi,

I have an ICS 6.1 server which has, basically, shut itself down. Most of the ICSD services have warnings against them:
service icsd status
Status Alcatel Supervision Client:
Application (pid 3126) is [STARTED]
Status Alcatel Supervision Agent:
Application (pid 3016) is [STARTED]
Alcatel Acapi Server:
Application is [WARNING]
Starter (pid 3247) is [STARTED]
Alcatel Application Server:
Application is [RUNNING]
Starter (pid 3501) is [STARTED]
Alcatel Logs Rotate:
Application is [RUNNING]
Starter (pid 3364) is [STARTED]
Alcatel Call Routing Service:
Application is [WARNING]
Starter (pid 3636) is [STARTED]
Alcatel Device Management Core:
Application is [WARNING]
Starter (pid 3762) is [STARTED]
Alcatel Data Access Service:
Application is [RUNNING]
Starter (pid 3877) is [STARTED]
Alcatel Enhanced Communication Service:
Application is [WARNING]
Starter (pid 4119) is [STARTED]
Alcatel Exchange 2007 Connector Server:
Application is [WARNING]
Starter (pid 3998) is [STARTED]
Alcatel Enterprise Mobility Server:
Application is [WARNING]
Starter (pid 4240) is [STARTED]
Alcatel Events Server:
Application is [WARNING]
Starter (pid 4361) is [STARTED]
Flexlm Server:
Application is [WARNING]
Starter (pid 10524) is [STARTED]
Alcatel IMAP4 Front End:
Application is [RUNNING]
Starter (pid 4597) is [STARTED]
Alcatel Integrated Messaging Service:
Application is [WARNING]
Starter (pid 4722) is [STARTED]
Ldap Server:
Application is [RUNNING]
Starter (pid 4835) is [STARTED]
Alcatel Mail Access Service Component:
Application is [WARNING]
Starter (pid 5007) is [STARTED]
Alcatel Media Server:
Application is [WARNING]
Starter (pid 5143) is [STARTED]
Alcatel Omni Sip Server:
Application is [WARNING]
Starter (pid 5273) is [STARTED]
Alcatel Open Telephony Server:
Application is [WARNING]
Starter (pid 5401) is [STARTED]
Alcatel Pcx Management Service:
Application is [WARNING]
Starter (pid 5520) is [STARTED]
Alcatel Presentation Server:
Application is [WARNING]
Starter (pid 5701) is [STARTED]
Sybase Server:
Application is [RUNNING]
Starter (pid 5816) is [STARTED]
Tomcat Server:
Application is [RUNNING]
Starter (pid 5929) is [STARTED]
Alcatel Universal Directory Access Service:
Application is [WARNING]
Starter (pid 6078) is [STARTED]
Alcatel Unified Management Framework Core:
Application is [WARNING]
Starter (pid 6209) is [STARTED]

I believe this has something to do with FlexLM as every time the flexlmd service is started, the alcotuc.lic file is reduced to 0k. I can copy the license file back on to the server but when it is rebooted or the services are restarted, the license file is 'deleted'.

lmstat then shows the following:
./lmstat
lmstat - Copyright (c) 1989-2007 Macrovision Europe Ltd. and/or Macrovision Corporation. All Rights Reserved.
Flexible License Manager status on Tue 10/30/2012 11:09

Error getting status: No SERVER lines in license file. (-13,66)

Once the license file is copied over again, I get this:

./lmstat
lmstat - Copyright (c) 1989-2007 Macrovision Europe Ltd. and/or Macrovision Corporation. All Rights Reserved.
Flexible License Manager status on Tue 10/30/2012 11:10

License server status: 27000@otuc.server
License file(s) on otuc.server: /usr/local/flexlm/licenses/license.dat:@otuc.server:alcotuc.lic:

lmgrd is not running: Cannot connect to license server system. (-15,570:115 "Operation now in progress")

I've replaced the real server name here :-)

Has anyone got any ideas? Is it possible to re-install FlexLM or will I have to re-install the entire server?

jasic
Member
Posts: 140
Joined: 14 Oct 2005 09:18

Re: FlexLM error

Post by jasic » 30 Oct 2012 16:49

What stand in the flexlm log?

User avatar
cavagnaro
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 6942
Joined: 14 Sep 2005 19:45
Location: Brasil, Porto Alegre
Contact:

Re: FlexLM error

Post by cavagnaro » 31 Oct 2012 12:19

Hum...by any chance did you upgraded your license file??? That should only happen if you installed with an older version of the license file a new version of ICS. It will work for a few days (read documentation) and then security level raises deleting it and it should even delete your system users
Ignorance is not the problem, the problem is the one who doesn't want to learn

OTUC/ICS ACFE/ACSE R3.0/4.0/5.0/6.0
Certified Genesys CIV 8.5
Certified Genesys Troubleshooting 8.5
Certified Genesys BEP 8.x
Genesys Developer

Post Reply

Return to “OTUC”