vitalqip not work with pxe help ?

Post Reply
MAOR
Member
Posts: 2
Joined: 12 Dec 2013 09:24

vitalqip not work with pxe help ?

Post by MAOR » 13 Dec 2013 00:21

hello to all
i have tftp server for pxe boot in 192.168.1.200
i have microsoft 2008 dhcp with address 192.168.1.1
i create a scope with option 66 and 67 and the pxe server work
when i have new computer in the network i preas f12 and
the computer was get from the dhcp ip addresss
and next server ip that point to tftp server and the proccess work fine
now i replace the dhcp to vitalqip dhcp 192.168.1.1
i bulid dhcp scope with the option 66 and 67
but this not work
the new computer get the ip from the dhco and not get the next ip server
becaus that the new computer think that the tftp server is the dhcp vitalqip
i need help ???
how i configure the dhcp scope in vitalqip
that new computer get the nexst server ip and the pxe boot work ?
thank

srenner
Member
Posts: 1
Joined: 27 Jun 2013 15:03

Re: vitalqip not work with pxe help ?

Post by srenner » 16 Dec 2013 19:40

For PXE boot, you need to use BootP not DHCP. Change the object type to BootP and enter the MAC address of the device and push to the DHCP server.

MAOR
Member
Posts: 2
Joined: 12 Dec 2013 09:24

Re: vitalqip not work with pxe help ?

Post by MAOR » 17 Dec 2013 14:48

Thank you for you answer
but i not understand
The vitalqip dhcp not support in option 66 and 67
how i config the vitalqip dhcp scope to point to my tftp
server
The networ
192.168.1.1 vital qip dhcp
192.168.1.200 tftp serverc
I do not how to create the dhcp Scope
Which option i need to set
thank you
maor

mgramlic
Member
Posts: 2
Joined: 18 Jun 2016 21:45

Re: vitalqip not work with pxe help ?

Post by mgramlic » 18 Jun 2016 22:09

We have PXE working with VitalQIP DHCP. We're using the following PXE related options.

66 - TFTP Server Name (IP or hostname)
67 - Bootfile Name
52 - Option Overload = Set value to 2

The PXE client would get an IP, mask, GW, etc but would stop at "PXE-E32: TFTP open timeout". When we set option 52 to 2 that solved that problem. Option 66 for TFTP server uses sname field which led me to this option. It was a shot in the dark that paid off for once.

Page 918 of the "VitalQIP Release 8.0 PR5 Web Client Users Guide"
Option Overload - This option is used to indicate that the DHCP sname or file fields are being overloaded by using them to carry DHCP options. A DHCP server inserts this option if the returned parameters exceed the usual space allotted for options. If this option is present, the client interprets the specified additional fields after it concludes interpretation of the standard option fields. Legal values for this option are as follows:
1 - The file field is used to hold options
2 - The sname field is used to hold options
3 - Both fields are used to hold options

MARTY GRAMLICK
Senior Network Engineer, Specialist
Network Infrastructure
The University of Chicago Medicine

Post Reply

Return to “VitalQIP”