Faxserver recieves Faxes, but sending fax per smtp to user not working

Post Reply
mozi
Member
Posts: 86
Joined: 10 Oct 2005 11:52
Location: Germany / Bernloch

Faxserver recieves Faxes, but sending fax per smtp to user not working

Post by mozi » 03 Feb 2016 10:48

We have the same faxserver problem on 3 different installations.
Faxserver recieves faxes, but is not able to send the fax per smtp to users e-mail address.
All services are running,
in the smtp.log, there is this message:

(1)(2016/02/01 16:29:15.290)( 70675344)(ComponentReplicaImpl::ActivateAsStandby ): Activating component 'Gateway'
(2)(2016/02/01 16:29:18.292)( 70675344)(EXG-10-013 ): system exception, ID 'IDL:omg.org/CORBA/TRANSIENT:1.0'OMG minor code (2), described as '*unknown description*', completed = NO

How can we solve this problem?
thanks in advance
regards Mozi

mozi
Member
Posts: 86
Joined: 10 Oct 2005 11:52
Location: Germany / Bernloch

Re: Faxserver recieves Faxes, but sending fax per smtp to user not working

Post by mozi » 03 Feb 2016 11:14

Here are the results aof the tests:


Tomcat is running

[root@faxsrv ~]# service tomcat-fax status
Tomcat is running...
[root@faxsrv ~]#

sql is running:

[root@faxsrv ~]# service mysql status
MySQL running (3296) [ OK ]
[root@faxsrv ~]#

iptabels are correct:

[root@faxsrv ~]# service iptables status
Table: nat
Chain PREROUTING (policy ACCEPT)
num target prot opt source destination
1 REDIRECT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:25 redir ports 8825
2 REDIRECT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:80 redir ports 8080
3 REDIRECT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:443 redir ports 8443

Chain POSTROUTING (policy ACCEPT)
num target prot opt source destination

Chain OUTPUT (policy ACCEPT)
num target prot opt source destination

[root@faxsrv ~]#



services are running:

test via ps
[root@faxsrv ~]# ps -aef |grep XM
102 3843 1 0 Feb01 ? 00:00:00 /opt/ofs/Bin/XMSnmpAgent
102 10344 1 0 01:03 ? 00:00:04 /opt/ofs/Bin/XMProxy
102 10378 1 0 01:03 ? 00:00:08 /opt/ofs/Bin/XMSmtpGateway
102 10400 1 0 01:03 ? 00:00:04 /opt/ofs/Bin/XMXmlGateway
102 10449 1 0 01:03 ? 00:00:01 /opt/ofs/Bin/XMDocumentRasterizer
102 10477 1 0 01:03 ? 00:00:14 /opt/ofs/Bin/XMFaxDriver
102 10504 1 0 01:03 ? 00:00:11 /opt/ofs/Bin/XMFaxArchive
102 10532 1 0 01:03 ? 00:00:11 /opt/ofs/Bin/XMFaxManager
102 10556 1 0 01:03 ? 00:00:04 /opt/ofs/Bin/XMCoConfig
102 10608 1 0 01:03 ? 00:00:26 /opt/ofs/Bin/XMConfigManager
102 10632 1 0 01:03 ? 00:00:18 /opt/ofs/Bin/XMFaultTolerance
root 12942 12891 0 16:53 pts/0 00:00:00 grep XM

test via script:

[root@faxsrv ~]# /opt/ofs/scripts/xmservices status
XMFaultTolerance (pid 10632) is running...
XMConfigManager (pid 10608) is running...
XMCoConfig (pid 10556) is running...
XMFaxManager (pid 10532) is running...
XMXmlGateway (pid 10400) is running...
XMFaxArchive (pid 10504) is running...
XMSmtpGateway (pid 10378) is running...
XMDocumentRasterizer (pid 10449) is running...
XMFaxDriver (pid 10477) is running...
XMSnmpAgent (pid 3843) is running...
XMProxy (pid 10344) is running...
[root@faxsrv ~]#


smtp to e-mailserver is working:


[root@faxsrv ~]# telnet mail1.comp.local 25
Trying 172.16.8.65...
Connected to mail1.comp.local (172.16.8.65).
Escape character is '^]'.
220 mail1.comp.local Microsoft ESMTP MAIL Service ready at Wed, 3 Feb 2016 17:07:27 +0100
helo
250 mail1.comp.local Hello [172.16.8.99]

User avatar
cavagnaro
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 6998
Joined: 14 Sep 2005 19:45
Location: Brasil, Porto Alegre
Contact:

Re: Faxserver recieves Faxes, but sending fax per smtp to user not working

Post by cavagnaro » 03 Feb 2016 12:18

Do a capture on that SMTP connection against your email server. What does Email Server logs indicate?
Ignorance is not the problem, the problem is the one who doesn't want to learn

OTUC/ICS ACFE/ACSE R3.0/4.0/5.0/6.0
Certified Genesys CIV 8.5
Certified Genesys Troubleshooting 8.5
Certified Genesys BEP 8.x
Genesys Developer

mozi
Member
Posts: 86
Joined: 10 Oct 2005 11:52
Location: Germany / Bernloch

Re: Faxserver recieves Faxes, but sending fax per smtp to user not working

Post by mozi » 04 Feb 2016 03:29

I did a tcpdump on faxserver

when a fax is recieved, the fax is put in the users inbox and the smtp.log shows the CORBA error, an in the tcpdump there is no entry with the faxservers IP Address.

Could i be a license Problem?

the smtp log Shows this:
(1)(2016/02/04 09:15:44.670)( 49630096)(XMedius::TraderHelper::QueryOffer ): std exception : Trading service not found. Type : LicenseManagerGroup, Constraint : {}
(1)(2016/02/04 09:15:44.670)( 49630096)(XMedius::TraderHelper::CallFirst ): std exception : Trading service not found
(2)(2016/02/04 09:15:44.670)( 49630096)(FloatingLicense::Acquire ): std::exception: Trading service not found

sipossz
Member
Posts: 2
Joined: 06 Apr 2016 07:50

Re: Faxserver recieves Faxes, but sending fax per smtp to user not working

Post by sipossz » 06 Apr 2016 07:55

I have the same problem for the last two weeks.

The faxes not provided to the email address, but the system alert notifications are working well.
I have the same error messages in the smtp.log

User avatar
cavagnaro
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 6998
Joined: 14 Sep 2005 19:45
Location: Brasil, Porto Alegre
Contact:

Re: Faxserver recieves Faxes, but sending fax per smtp to user not working

Post by cavagnaro » 06 Apr 2016 12:03

Is port 25 working? Do a nestat and check your firewall iptables. Try to run the Checksystem script

Enviado de meu C6603 usando Tapatalk
Ignorance is not the problem, the problem is the one who doesn't want to learn

OTUC/ICS ACFE/ACSE R3.0/4.0/5.0/6.0
Certified Genesys CIV 8.5
Certified Genesys Troubleshooting 8.5
Certified Genesys BEP 8.x
Genesys Developer

sipossz
Member
Posts: 2
Joined: 06 Apr 2016 07:50

Re: Faxserver recieves Faxes, but sending fax per smtp to user not working

Post by sipossz » 07 Apr 2016 02:58

Port 25 is up and working well from the ssh prompt. It looks the fax serer has lost the connection with it's the xmsmtpgateway service. There is no try to access the smtp server in the smtp.log and also no packet in the capture file to the smtp server, so it would be an internal problem in the software.

In the System Monitor/Service Status screen XMSmtpGateway status is "Fault" and membership is "----". The XMSmtpGateway service in opsys level looks running well and the system looks helthy.

All the system alerts are sent through the SMTP server, but none of the faxes are provided.

Any idea? Thanks!

User avatar
tgn
Member
Posts: 795
Joined: 30 Dec 2009 17:59
Location: Germany

Re: Faxserver recieves Faxes, but sending fax per smtp to user not working

Post by tgn » 07 Apr 2016 13:26

restart fax services...?
reboot server...?

regards...


--- back to basics... focus your eyes on the essential things... ---
--- back to basics... focus your eyes to the essential things... ---

OXE_4400
Member
Posts: 499
Joined: 19 Jul 2007 06:22
Location: Lithuania, Europe

Re: Faxserver recieves Faxes, but sending fax per smtp to user not working

Post by OXE_4400 » 08 Apr 2016 15:39

Do You have email Integration license for 8450FS ?
Taken from real license file:
Email Integration = 1

mozi
Member
Posts: 86
Joined: 10 Oct 2005 11:52
Location: Germany / Bernloch

Re: Faxserver recieves Faxes, but sending fax per smtp to user not working

Post by mozi » 15 Nov 2016 16:10

Problem is solved,
Very hard to find the cause.
Someone from the development department connects randomly new Controllers to the Network and an ip address is assigend via dhcp.
Unfortunatly he uses 'localhost' as hostname. So the DNS entry 'localhost' is changed to this new ip address.
During that time the faxserver has problems to resolve the Name localhost.
Regards Mozi

Post Reply

Return to “OmniTouch 8450 Fax Software”