PIMphony updates secure channel failure

Post Reply
User avatar
bcmir
Member
Posts: 69
Joined: 10 Jan 2010 18:15

PIMphony updates secure channel failure

Post by bcmir »

Hi all.. Has anyone seen this PIMphony error ?


Windows 10 x64
OXO Connect 2.1.32
PIMphony 6.8.3235
PIMphony Online Update
Error during communication with Server: SecureChannelFailure

I suspect it' s windows issue, I can see the error in Event Viewer.
Very hard to troubleshoot.. I have an eSR lodged ... but am not holding my breath :(
User avatar
fe80
Member
Posts: 73
Joined: 08 Sep 2015 09:15
Location: Germany

Re: PIMphony updates secure channel failure

Post by fe80 »

Yes. Its caused by a cipher suite mismatch between PIMphony and OXO. Turning off HTTPS is a temporary solution.
User avatar
bcmir
Member
Posts: 69
Joined: 10 Jan 2010 18:15

Re: PIMphony updates secure channel failure

Post by bcmir »

This is what ALE came back with... Issue is reproducing in some of the PC's locally. While clicking on "Onlineupdate", PIMphony is communicating with OXO via SSLv3 in handshake mechanism and getting failed. For this, we make PIMphony to use TLS1 only in handshake mechanism. Now, online update is working in PIMphony.
ner0
Member
Posts: 4
Joined: 03 May 2013 10:19

Re: PIMphony updates secure channel failure

Post by ner0 »

Sorry for reviving this thread, I'm having this same issue and I'm not sure how to solve this. Do I have to update any software component on the client side?

Previously I was using PIMphony 6.8.3240 and it was giving me a SendFailure error on update attempt, the update window wouldn't even come up. Then I uninstalled PIMphony and installed build 6.8.3300, configured it to connect to PCX through HTTP port since it won't even accept HTTPS (Central Services do not exist on your system or are not accessible), although HTTPS is accessible through OMC and web browser.
fe80 wrote: 12 Jan 2018 03:35 Yes. Its caused by a cipher suite mismatch between PIMphony and OXO. Turning off HTTPS is a temporary solution.
I'm not using HTTPS to connect to the PCX, and I still have the issue.
bcmir wrote: 21 Mar 2018 00:24 This is what ALE came back with... Issue is reproducing in some of the PC's locally. While clicking on "Onlineupdate", PIMphony is communicating with OXO via SSLv3 in handshake mechanism and getting failed. For this, we make PIMphony to use TLS1 only in handshake mechanism. Now, online update is working in PIMphony.
How do you go about forcing TLS1 handshake? Btw, we don't have any cloud service such as OmniPCX Office RCE.

Thanks for the help.
Post Reply

Return to “H323 / IP / Pimphony”