Create a service from one CE to the other via VPRN

Post Reply
thakadbd
Member
Posts: 12
Joined: 26 Oct 2015 07:32

Create a service from one CE to the other via VPRN

Post by thakadbd » 21 Sep 2016 07:05

I have successfully created the VPRN service. I have two CE which are connected to the VPRN and the routing protocol between the CE and PE routers have been done successfully. Using the command oam vpn-ping service-id source x.x.x.x destination y.y.y.y I am able to verify that the VPRN works. I want to create a service that will originate on one CE and terminate on the other CE via the VPRN and until now I cannot figure out how to do this.

Also when I ping the remote CE from one CE I am getting an error message.

thakadbd
Member
Posts: 12
Joined: 26 Oct 2015 07:32

Re: Create a service from one CE to the other via VPRN

Post by thakadbd » 21 Sep 2016 10:16

I think the solution is in configuring ospf export policy to on the CE to advertise the system address and configure the export policy on the PE to advertise the VPN. Can anyone show me how to accomplish these task.

hbaloi
Member
Posts: 16
Joined: 30 Jul 2016 07:39

Re: Create a service from one CE to the other via VPRN

Post by hbaloi » 31 Oct 2016 04:25

Hello,

I have a VPRN configured between on SAR18 and another SR7 at far end . But the service randomly goes down and i have do reboot the SAR18 to restore it.
Any idea in how to solve it definitely ?

Regards

Stoffen
Member
Posts: 129
Joined: 23 May 2014 05:32
Location: Norway

Re: Create a service from one CE to the other via VPRN

Post by Stoffen » 04 Nov 2016 04:02

hbaloi wrote:Hello,

I have a VPRN configured between on SAR18 and another SR7 at far end . But the service randomly goes down and i have do reboot the SAR18 to restore it.
Any idea in how to solve it definitely ?

Regards
Hi.
Its not easy to say how to solve this with no information.

Is it only one particular VPRN service that suffers from this problem, or does it affect all/other services on SAR18 as well?
Any information in log when the problem occurs?

Can you give us the output from "show service id <id> all" when the problem is present?
[flash=]
Christoffer

Network System Expert Norway
Nokia SRA #265
Alcatel-Lucent SRC 3RP Certified #552
Alcatel-Lucent SRC NRS-2 Certified #1104
Huawei HCNP Routing & Switching certified
Cisco CCNP Certified
LinkedIN
[/flash]

hbaloi
Member
Posts: 16
Joined: 30 Jul 2016 07:39

Re: Create a service from one CE to the other via VPRN

Post by hbaloi » 09 Jan 2017 02:24

Dear Chris,

Thank you for your reply . But this one was sorted out ( it was the microwave link tha was flapping, causing detours and blocks ).

The out of the service was always the same ( never down ) :

A:Benfica# show service id 3312601 base

===============================================================================
Service Basic Information
===============================================================================
Service Id : 3312601
Service Type : VPRN
Name : IuB_MHRNC03
Description : IuB over IP VPRN to MHRNC03
Customer Id : 1
Last Status Change: 12/16/2016 09:49:58
Last Mgmt Change : 12/16/2016 09:49:58
Admin State : Up Oper State : Up

Route Dist. : 65000:3312601117 VPRN Type : regular
AS Number : 65000 Router Id : 10.1.16.117
ECMP : Enabled ECMP Max Routes : 1
Max IPv4 Routes : No Limit Auto Bind : None
Max IPv6 Routes : No Limit
Ignore NH Metric : Disabled
Vrf Target : target:65000:33126*
Vrf Import : None
Vrf Export : None
MVPN Vrf Target : None
MVPN Vrf Import : None
MVPN Vrf Export : None

SAP Count : 14 SDP Bind Count : 1

-------------------------------------------------------------------------------
Service Access & Destination Points
-------------------------------------------------------------------------------
Identifier Type AdmMTU OprMTU Adm Opr
-------------------------------------------------------------------------------
sap:1/3/1:2198 q-tag 1518 1518 Up Up
sap:1/3/2:2150 q-tag 1518 1518 Up Up
sap:1/3/8:2080 q-tag 1518 1518 Up Up
sap:1/3/8:2123 q-tag 1518 1518 Up Up
sap:1/4/1:2199 q-tag 1518 1518 Up Up
sap:1/4/1:2221 q-tag 1518 1518 Up Up
sap:1/4/2:2197 q-tag 1518 1518 Up Up
sap:1/4/5:2124 q-tag 1518 1518 Up Up
sap:1/4/6:2153 q-tag 1518 1518 Up Up
sap:1/5/2:2014 q-tag 1518 1518 Up Up
sap:1/5/3:2044 q-tag 1518 1518 Up Up
sap:1/5/4:2174 q-tag 1518 1518 Up Up
sap:1/5/5:2143 q-tag 1518 1518 Up Up
sap:1/5/6:2099 q-tag 1518 1518 Up Up
sdp:126:3312601 S(10.1.16.126) n/a 0 1546 Up Up
===============================================================================
* indicates that the corresponding row element may have been truncated.
A:Benfica#



Logs :

hbaloi
Member
Posts: 16
Joined: 30 Jul 2016 07:39

Creating na E1 with encap-ppp in mode network failue

Post by hbaloi » 06 Feb 2019 08:32

Hi Friends,

Im tyring to config an E1 inside a STM1, with channel-group 1 using encap-ppp, and im getting the error below. Can anyone help :

*A:MHBHR01>config>port>tdm>e1>channel-group# encap-type ppp-auto
MINOR: PMGR #1005 Invalid value - 1/2/4.1.1.1.1, Invalid Mode access or Encap ppp-auto

mivens
Member
Posts: 256
Joined: 28 Sep 2012 06:34

Re: Create a service from one CE to the other via VPRN

Post by mivens » 11 Feb 2019 07:56

ppp-auto is only valid if the port is in network mode.
Is it configured as an access port?

Post Reply

Return to “7750 SR”