Multicast only routing one direction

Post Reply
songstadw
Member
Posts: 14
Joined: 15 Feb 2019 18:12

Multicast only routing one direction

Post by songstadw »

I have a PIM-SM setup with a source connected to a 6900 which then connects to a pair of 6900S configured with advanced routing which routes to another 6900 building router and finally to a 6450 and the listeners.

Source (10.0.240.75) -> [6900 switch (VLAN 240)] -> [2x 6900 router1 (VLAN 240] -> [6900 router2] -> [6450 switch (VLAN 301)] - listener (10.10.1.182)

Routers are using OSPF
Querying and Querier-Forwarding are enabled on the switches.
This configuration works from left to right. But if I create a source to the right side of the diagram and a listener on the left, multicast traffic does not pass.

Router1:
! IP Multicast:
ip load pim
ip pim interface "VLAN0001"
ip pim interface "VLAN0721"
ip pim interface "VLAN0722"
ip pim interface "Core2-OSPFRtr"
ip pim interface "VLAN0240"
ip pim interface "vlan0097"
ip pim cbsr 10.0.0.1 priority 101 mask-length 4
ip pim candidate-rp 10.0.0.1 239.0.1.0/24 priority 101 interval 100
ip pim static-rp 239.0.1.0/24 10.0.0.1 priority 10
ip pim bidir admin-state enable
ip pim bfd-state enable
ip pim mbr all-sources
ip pim sparse admin-state enable
ip pim dense admin-state disable
ipv6 pim sparse admin-state disable
ipv6 pim dense admin-state disable

! DVMRP:
ip load dvmrp
ip dvmrp admin-state disable

! IPMR:
ip mroute mbr admin-state enable
ip mroute interface "VLAN0721" ttl 16
ip mroute interface "VLAN0722" ttl 16
ip mroute interface "Core2-OSPFRtr" ttl 11
ip mroute interface "VLAN0240" ttl 16

Router2:
-> show configuration snapshot ipmr
! IP Multicast:
ip load pim
ip pim interface "OSPF-Router"
ip pim interface "TS-LAN" stub
ip pim interface "ESC-LAN"
ip pim interface "VLAN1001"
ip pim interface "VLAN1017"
ip pim sparse admin-state enable
ip pim dense admin-state disable
ipv6 pim sparse admin-state disable
ipv6 pim dense admin-state disable

! DVMRP:
ip load dvmrp
ip dvmrp admin-state disable

! IPMR:


Any ideas?

*edited to reflect actual config as previously posted config was not the partially working one
Thank you,
Bill
songstadw
Member
Posts: 14
Joined: 15 Feb 2019 18:12

Re: Multicast only routing one direction

Post by songstadw »

This turned out to be a bad mix of OSPF and static routing. OSPF was enabled but not configured on one half of the pair of routers at one end. So it appears that Multicast routing was following static routes some times and was following non-existent OSPF routes sometimes. This caused Multicast packets to get dropped some times. Converting all routers to OSPF corrected a bunch of multicast routing issues. My recommendation is to not mix routing protocols whenever multicast routing is involved. Normal routing worked fine, but multicast hated it.
Thank you,
Bill
silvio
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 1538
Joined: 01 Jul 2008 10:51
Location: Germany

Re: Multicast only routing one direction

Post by silvio »

Hi Bill,
thanks for your solution of the problem. In my knowledge PIM always need an underlaying dynamic routing protocoll (like OSPF or RIP) between all routers.
best regards
Silvio
Post Reply

Return to “OmniSwitch 6900”