ssh + ""exec request failed on channel 0"

Post Reply
plegrand
Member
Posts: 21
Joined: 13 Mar 2017 11:19

ssh + ""exec request failed on channel 0"

Post by plegrand » 07 May 2019 04:27

Hello,
i've got a little question about ssh on OS6450.
Everything works fine if i use ssh like that :

Code: Select all

ssh admin@192.168.1.1 
  
Welcome to the Alcatel-Lucent OmniSwitch 6450
Software Version 6.6.5.63.R02 GA, December 16, 2014. 

Copyright(c), 1994-2014 Alcatel-Lucent. All Rights reserved.

OmniSwitch(TM) is a trademark of Alcatel-Lucent registered
in the United States Patent and Trademark Office.
  
SW001-> dir

Listing Directory /flash:

-rw       310 Mar  1  2000 boot.params 
drw      2048 Sep  3  2002 certified/
drw      2048 Sep  3  2002 working/
-rw     64000 May  7 10:20 swlog1.log 
-rw     64000 May 21  2000 swlog2.log 
-rw        12 Jan  1  2001 boot.slot.cfg 
drw      2048 Jan  1  2001 switch/
drw      2048 Jan  1  2001 network/
-rw        20 Jan  1  2001 installed 

	55750656 bytes free

SW001-> exit
Connection to 192.168.1.1 closed.
But i would like launch directly a command and i've got an error message :

Code: Select all

ssh admin@192.168.1.1 dir
exec request failed on channel 0

Is there a way to do that from a linux client ?
Thanks for your help

plegrand
Member
Posts: 21
Joined: 13 Mar 2017 11:19

Re: ssh + ""exec request failed on channel 0"

Post by plegrand » 07 May 2019 08:35

The goal is to script this command : "show spantree ports blocking"

plegrand
Member
Posts: 21
Joined: 13 Mar 2017 11:19

Re: ssh + ""exec request failed on channel 0"

Post by plegrand » 13 May 2019 09:58

Silvio ;-)

Any idea about that ?

Post Reply

Return to “OmniSwitch 6450”