OTCV with iPhone7

Post Reply
PeterT
Member
Posts: 4
Joined: 10 Jan 2017 03:24

OTCV with iPhone7

Post by PeterT » 10 Jan 2017 03:38

I am using OTCV on iPhone 5S for quite a while without problem.
I would now like to use a new iPhone7 with most recent OTCV-app release.
I can connect to the OMNI-PCX with my iPhone 5S, but I can't with iPhone7.
I did already try:
* delete an (re-)add the user "MyIC Mobile"
* delete the iPhone-App and (re-)install it
I still can connect using the iPhone5S, but not with the iPhone7. It can't be a setup issue.
It must have to do with certificates. The iPhone7 never asked to confirm any certificate. How can I force this.
iPhone7-App always reports "Anmeldefehler"
Log entry:
2017-01-08 12:29:56.826 MyIC_Mobile[678:169033] [KEYCHAIN] error in matching while enumerate certificates

User avatar
frank
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 12755
Joined: 06 Jul 2004 00:18
Location: New York
Contact:

Re: OTCV with iPhone7

Post by frank » 08 Feb 2017 21:20

Hi Peter,

I am using an iPhone 7.
Are your certificates self signed ?
Code Free Or Die

PeterT
Member
Posts: 4
Joined: 10 Jan 2017 03:24

Re: OTCV with iPhone7

Post by PeterT » 09 Feb 2017 02:14

Not sure ... don't think so.
Where can I delete the "old" certificate with iPhone5 to allow new certificate generation with iPhone7?

User avatar
frank
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 12755
Joined: 06 Jul 2004 00:18
Location: New York
Contact:

Re: OTCV with iPhone7

Post by frank » 09 Feb 2017 12:57

Ha.. I don t remember.. but it was a pain in the butt.
Anyone else can give a piece of info ?
Code Free Or Die

PeterT
Member
Posts: 4
Joined: 10 Jan 2017 03:24

Re: OTCV with iPhone7

Post by PeterT » 11 Dec 2018 12:02

Can anyone help?
IO have still not solved this problem.
It works with iPhone 5S, but I cannot get it work on any other iPhone.
Where / how can I delete the existig license to allow a new iPhone to be connected?

User avatar
KoenC
Member
Posts: 48
Joined: 18 Feb 2015 10:38
Location: Belgium

Re: OTCV with iPhone7

Post by KoenC » 02 Jan 2019 09:38

Hi,
Not a 100% sure, but I think the OXO's certificate stays stored in the iPhone 5s,
did you try to delete it from the phone before the reïnstallation of the app?
This needs to be done with the early version of the OTCV app if you have the installation with that app.
I'd try it like this:

1. Go to your iPhone 5s settings
2. Go to your iPhone OTCV app settings
3. activate the "delete certifications"
4. activate the "reset all user data" button
5. now delete the application and delete the My IC Mobile user
6. create a new My IC Mobile user
7. download the new app on your Iphone 7 and reconfigure it

Hope this solves your issue, good luck.
If I'm ever on life support, unplug me. Then plug me back in, see if that works...

PeterT
Member
Posts: 4
Joined: 10 Jan 2017 03:24

Re: OTCV with iPhone7

Post by PeterT » 07 Jan 2019 06:10

Many thanks for your reply.

I had already tried this ... and I did try it again: still get the "Login Error" on the OpenTouch APP.

When I then re-install either OpenTouch (or OTCV) on my iPhone 5S, it immediatelly synchronizes, downloads the certificate and works.

Can't get the iPhone7 or iPhone X to do so.

Note:
When I connect with the iPhone5S, the iPhone details are shown in the "Basestation/User List".
When I try to connect with another iPhone, nothing is reflected in that list (newly setup MyIC Mobile profile)

I do get this error in the log:
[KEYCHAIN] error -25300 in matching while enumerate certificates

It is quite frustrating.
There must be some sort of license, ID, etc. stored in the OmniPCX which I need to locate and delete.

Post Reply

Return to “OpenTouch Conversation”