PIM Multicast Routing

Post Reply
alcashite
Member
Posts: 12
Joined: 18 Apr 2017 03:53

PIM Multicast Routing

Post by alcashite » 21 Mar 2019 06:26

Hi,

We are trying to get multicast routing across three 6860 switches. We have been successful with DVMRP which seems to be very simple to set up but wanted to also test PIM.

We have three switches set up linked via layer 3 point to point VLANs and OSPF. One is acting as the core and two are hanging off this as edge switches. We then have separate VLAN on each edge switch to connect the multicast end points to. I have tried enabling various commands for PIM but can't seem to get the multicast routed. DVMRP works fine on this setup.

Current configs:

Core switch

Code: Select all

! VLAN:
vlan 1 admin-state disable
vlan 920 admin-state enable
vlan 930 admin-state enable
vlan 920 members linkagg 1 tagged
vlan 930 members linkagg 2 tagged

! IP:
ip interface "Loopback0" address 10.254.0.10
ip interface "vlan-930" address 10.254.1.30 mask 255.255.255.254 vlan 930 ifindex 1
ip interface "vlan-920" address 10.254.1.20 mask 255.255.255.254 vlan 920 ifindex 2

! IPMS:
ip multicast admin-state enable

! IP Multicast:
ip load pim
ip pim interface "vlan-930"
ip pim interface "vlan-920"
ip pim interface "Loopback0"
ip pim cbsr 10.254.0.10
ip pim candidate-rp 10.254.0.10 224.0.0.0/4
ip pim sparse admin-state enable
ip pim dense admin-state disable
ipv6 pim sparse admin-state disable
ipv6 pim dense admin-state disable
Edge switch 1

Code: Select all

! VLAN:
vlan 1 admin-state disable
vlan 920 admin-state enable
vlan 920 name "Test-Edge-1-to-Test-Core-1_OSPF"
vlan 1030 admin-state enable
vlan 1030 name "AV-EQUIP"
vlan 1030 members port 1/1/1 untagged
vlan 920 members linkagg 1 tagged

! IP:
ip interface "Loopback0" address 10.254.0.20
ip interface "vlan-920" address 10.254.1.21 mask 255.255.255.254 vlan 920 ifindex 1
ip interface "vlan-AV-EQUIP" address 10.149.20.1 mask 255.255.255.0 vlan 1030 ifindex 2

! IP Multicast:
ip load pim
ip pim interface "vlan-920"
ip pim interface "vlan-AV-EQUIP"
ip pim sparse admin-state enable
ip pim dense admin-state disable
ipv6 pim sparse admin-state disable
ipv6 pim dense admin-state disable
Edge switch 2

Code: Select all

! VLAN:
vlan 1 admin-state disable
vlan 930 admin-state enable
vlan 930 name "Test-Edge-1-to-Test-Core-1_OSPF"
vlan 1030 admin-state enable
vlan 1030 name "AV-EQUIP"
vlan 1030 members port 1/1/1 untagged
vlan 930 members linkagg 1 tagged

! IP:
ip interface "Loopback0" address 10.254.0.30
ip interface "vlan-930" address 10.254.1.31 mask 255.255.255.254 vlan 930 ifindex 1
ip interface "vlan-AV-EQUIP" address 10.149.20.1 mask 255.255.255.0 vlan 1030 ifindex 2

! IP Multicast:
ip load pim
ip pim interface "vlan-930"
ip pim interface "vlan-AV-EQUIP"
ip pim sparse admin-state enable
ip pim dense admin-state disable
ipv6 pim sparse admin-state disable
ipv6 pim dense admin-state disable
Am I missing something?

Thanks.

silvio
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 1320
Joined: 01 Jul 2008 10:51
Location: Germany

Re: PIM Multicast Routing

Post by silvio » 25 Mar 2019 06:19

If the config is the real used one than routing can't work (with ospf or static...). You have at both edge switches the same network (AND SAME IP-INTERFACE) for the clients. So no one in vlan 1030 at sw1 can't reach anyone in vlan 1030 in sw2. Because PIM uses ospf it can't work too. Please solve this issue.
best regards
Silvio

Post Reply

Return to “OmniSwitch 6860 / 6860E”