SIP 404 Message on Outbound Faxes

sadim
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 500
Joined: 02 Jun 2006 07:11
Location: Portugal

Re: SIP 404 Message on Outbound Faxes

Post by sadim » 10 May 2017 10:47

And what about Ext Sip Gw 1 configuration. What is the remote ip addr.
If ok, did you already restart the sipmotor

Felix
Member
Posts: 16
Joined: 25 Nov 2011 09:46

Re: SIP 404 Message on Outbound Faxes

Post by Felix » 10 May 2017 12:09

Thanks Cavagnaro,

This is also correctly set but still not working.

Felix
Member
Posts: 16
Joined: 25 Nov 2011 09:46

Re: SIP 404 Message on Outbound Faxes

Post by Felix » 10 May 2017 12:10

Hi Sadim,

I am going to try a SIP motor restart this evening to see if I can get this working. I will let you know how I get on.

Felix
Member
Posts: 16
Joined: 25 Nov 2011 09:46

Re: SIP 404 Message on Outbound Faxes

Post by Felix » 10 May 2017 12:12

Also the Ext SIP GW 1 is the OpenTouch. the SIP EXT GW 4 is the Fax Server integrated into the OT. The remote domain in Gway1 to OT is the FQDN of the OT and the Fax Server it is the IP address of the OT. This is programmed as per the TC.

Thanks

Felix
Member
Posts: 16
Joined: 25 Nov 2011 09:46

Re: SIP 404 Message on Outbound Faxes

Post by Felix » 11 May 2017 06:47

Hi Still having issues even after a SIP motor restart. I have compared this to a working fax server and can see that the working uses the correct External Gateway which was set up for the fax server but the one I am having trouble with uses the External Gateway for the OT and not the Fax Server.

Working Trace
Wed May 10 09:32:50 2017 [CMotorCall::analyseRouting] 01325390001@10.100.5.15 NOT found in the dictionnary.
1494405170 -> Wed May 10 09:32:50 2017 [isDomainFromExtGw] Host from request is : 10.100.5.15.
Wed May 10 09:32:50 2017 [isDomainFromExtGw] User from request is : 01325390001
Wed May 10 09:32:50 2017 [isDomainFromExtGw]--> GwExt=2
Wed May 10 09:32:50 2017 [isDomainFromExtGw] CS : Selected gw 2
Wed May 10 09:32:50 2017 [CMotorCallManager::processNotInDico] 10.100.5.15 is from extGw 2.

Non Working
Thu May 11 10:38:39 2017 [CMotorCall::analyseRouting] 01276587997@10.234.5.163 NOT found in the dictionnary.
1494495519 -> Thu May 11 10:38:39 2017 [isDomainFromExtGw] Host from request is : 10.234.5.163.
Thu May 11 10:38:39 2017 [isDomainFromExtGw] User from request is : 01276587997
Thu May 11 10:38:39 2017 [CMotorCallManager::processNotInDico] 10.234.5.163 is from extGw 1.
Thu May 11 10:38:39 2017 isUserInDico] NOT found in the dictionnary.
Thu May 11 10:38:39 2017 [isAddrInDico] other sip user
Thu May 11 10:38:39 2017 11bb[CMotorCall::getUserType] End extGw=1.

How do I get this to route over the correct External Gateway which is 4? Its driving me nuts!

Thanks for all your help so far its much appreciated.

sadim
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 500
Joined: 02 Jun 2006 07:11
Location: Portugal

Re: SIP 404 Message on Outbound Faxes

Post by sadim » 11 May 2017 07:21

On the Fax Server, change the port from 5060 to 5360.

Felix
Member
Posts: 16
Joined: 25 Nov 2011 09:46

Re: SIP 404 Message on Outbound Faxes

Post by Felix » 11 May 2017 08:42

Hi Sadim,
In the SIP settings under "Driver" the local SIP UDP and TCP were 5360. I did change the port in the peer list and tested it but it didnt even reach the OXE on the SIP trace.

sadim
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 500
Joined: 02 Jun 2006 07:11
Location: Portugal

Re: SIP 404 Message on Outbound Faxes

Post by sadim » 11 May 2017 09:20

I am not Fax server expert, but from what i know, you must set the protocol (TCP or UDP) and the port, to match the values configured on OXE under the driver/general tab. In your case TCP and 5360. Since it is OTBE, the Fax Server and OT as same ip addr, so in your case the remote network for the fax ExtSipGw and for the OT ExtSipGw are the same. OXE selects the proper one by the port number.
Perhabs a fax server reset is needed ?

Felix
Member
Posts: 16
Joined: 25 Nov 2011 09:46

Re: SIP 404 Message on Outbound Faxes

Post by Felix » 11 May 2017 09:47

Hi Sadim,

Thats correct, all the parameters match in the external gateway and the Fax Server. In the latest OXE release you have to use TCP and not UDP as the Oxe will reject the outgoing fax, which it does.

The Ext Gway 1 is to the OT and is by FQDN and the Fax Server its to the OT IP address, this is again outlined in the documentation. I have tried a number of SIP motor restarts and also restarting the Fax services and also a complete reboot of the OTMS.

Next stop is to trash and rebuild the Fax server on the OT and install the latest version. I am working with tech support currently but even they are stumped!!

Thanks for your help so far and when I eventually get to the outcome of this I will let you know.

Post Reply

Return to “OTFC - OpenTouch Fax Center”