Page 1 of 2

Problems with SIP on OXO

Posted: 16 Dec 2009 12:14
by RobertBreu
Hi,

i have a problem with my SIP-Account on an OXO (Rel 7.1).
I can register by my provider (sipgate) and can receive calls (but only by the default attendant group) but i can't route the sip-call to an extenions and i can't dial out to another sipgate-account or to an isdn-number.
If it helps you i can attach the database so you can see my configuration.

Thanks
Robert

Re: Problems with SIP on OXO

Posted: 16 Dec 2009 13:44
by enio.eltz
Hi Robert

OXO doesn't understand a SIP gateway as extension or trunk. You can make and receive some calls through ARS table and private numbering plan from oxo to SIP gateway and from SIP gateway to oxo. I did some tests with a SIP gateway and it works more or less.

Best regards.

Re: Problems with SIP on OXO

Posted: 17 Dec 2009 14:53
by RobertBreu
That's new for me, i thought sip-trunking is a official feature since rel. 5?
I know that you can't connect sip-extensions to the oxo but trunking must be possible.
As i said before i can give you my database so you can see the config

Thanks

Re: Problems with SIP on OXO

Posted: 18 Dec 2009 08:35
by enio.eltz
Hi Robert

Since R5.00 SIP is avalliable in oxo.
I did some tests with external gateways in oxo but it didn't work very well due to dial numbers from gateway to oxo.
I read better your first post. Do you have this oxo logged in a SIP server to make external calls? I have some oxo with SIP servers ( VoIP SIP operators in Brazil ).
Send me its database that I see something.

Best ragards.

Re: Problems with SIP on OXO

Posted: 21 Dec 2009 05:51
by RobertBreu
Hi,

i have attached the database.
You have to delete the extension .txt and put the extension .cdb on the file...(Because the extension .cdb is not allowed in this forum!)

Re: Problems with SIP on OXO

Posted: 21 Dec 2009 06:20
by enio.eltz
Hi Robert

I saw its database. Your configuration seems OK, but you dont't have first step, VoIP-x daugther board and software keys for IP trunk.
Without VoIP-x daugther board and software key you don't get to talk.
With the VoIP board and software key in the oxo you need to do this on your system:

Go to voice over ip --> voip parameters --> general --> set the number of ip trunks at number of voip-trunk channels.
Go to external lines --> list of access --> see if it has the voip access.
Go to external lines --> list of trunks groups --> group #0 --> details --> put the voip access there.

I believe it will work.

Best regards.

Re: Problems with SIP on OXO

Posted: 21 Dec 2009 10:19
by RobertBreu
Ahh sorry this pbx is our lab-system and it seems that another guy put my key with the ip-trunk-licences away...the key was with ip-trunk-licences when i tested it (i was able to receive calls...). You think the config is right and it should work?

Re: Problems with SIP on OXO

Posted: 21 Dec 2009 10:56
by enio.eltz
Hi Robert

OK. Other thing, I saw you are without any configuration at ARS --> gateway parameters --> SIP numbers format index. In our configurations we use as 1 that you can see at ARS --> SIP public number, without this I didn't make calls either.
I had another problem with my schedule with the public operator. In all releases of oxo I tested when I send an invite to SIP server it answers asking 407 proxy authentication required. After this the oxo sends two packets, one ACK that meaning oxo understood and a re-invite. When the oxo sends the reinvite it reverses the dialled number with its A number identification at the message header. Due to this you don't get to make calls I believe. I needed to talk to our SIP provider ( Transit Brazil ) asking them to configure my public IP at the SIP server and this way it doesn't ask 407 proxy authentication required. The call goes ok.
You need to change the SIP numbers format index and if it doesn't works you will need to see the packets with a lan sniffer as wireshark to see if the SIP Server askes proxy.
As I saw I believe you configuration is not wrong and it will work.

Best regards.

Re: Problems with SIP on OXO

Posted: 12 Sep 2017 07:57
by bpcrew
hi robert,

do u have a solution 4 the sipgate trunk ???

my problem is i cant call out

Re: Problems with SIP on OXO

Posted: 13 Sep 2017 05:23
by ltatge
Hi,

Sipgate Trunk is validated by ALE. Search in Businessportal for the SIP-Profile. Works fine...

Regards