PIM routing pb

Post Reply
Alcaineo
Member
Posts: 2
Joined: 28 Oct 2021 08:22

PIM routing pb

Post by Alcaineo »

Hi,
We have a 6450 connected to a VC 6900 by one link with 802.1q
Two vlan 601 (operator) and 602 (camera which use multicast to stream the video)
We have made a simple configuraiotn on both switch (see below) but not video is available on the 6900.
It seems that the pim routing doesn't work.
We have put the ttl to 10 to be sure.
The 6450 is connected on the vc on 1/1/1 and the operator is on port 1/1/2

On 6450 :
ip multicast status enable
ip multicast querier-forwarding enable

On 6900 :
show configuration snapshot ip ipms ipmr
! IP:
ip interface "Loopback0" address 192.168.100.99
ip interface "VIDEO_SRV" address 172.16.200.251 mask 255.255.255.0 vlan 600 ifindex 4
ip interface "VIDEO_EXPLOIT" address 172.16.201.254 mask 255.255.255.0 vlan 601 ifindex 5
ip interface "VIDEO_CAM_IP_A" address 172.16.202.254 mask 255.255.255.0 vlan 602 ifindex 6

! IPMS:
ip multicast admin-state enable
ip multicast querying enable
ip multicast vlan 601 admin-state enable
ip multicast vlan 602 admin-state enable

! IP Multicast:
ip load pim
ip pim interface "VIDEO_SRV"
ip pim interface "VIDEO_EXPLOIT"
ip pim interface "VIDEO_CAM_IP_A"
ip pim interface "Loopback0"
ip pim static-rp 239.0.0.0/8 192.168.100.99
ip pim sparse admin-state enable
ip pim dense admin-state disable
ipv6 pim sparse admin-state disable
ipv6 pim dense admin-state disable

Here's the resul of some command regarding multicast PIm :
-> show ip multicast group | head

Total 4 Groups

Group Address Source Address Vlan/Service Interface Mode Static Count Life
---------------+---------------+--------------+----------------------+--------+-------+------+-----
239.16.202.1 0.0.0.0 vlan 601 1/1/2 exclude no 8 205
239.255.255.250 0.0.0.0 vlan 601 1/1/2 exclude no 8 197
239.16.202.1 0.0.0.0 vlan 602 1/1/1 exclude no 8 255
239.255.255.250 0.0.0.0 vlan 602 1/1/1 exclude no 7 256

show ip pim interface

Total 8 Interfaces

Interface Name IP Address Designated Hello J/P Oper BFD
Router Interval Interval Status Status
--------------------------------+---------------+---------------+--------+--------+--------+--------
VIDEO_SRV 172.16.200.251 172.16.200.251 30 60 enabled disabled
VIDEO_EXPLOIT 172.16.201.254 172.16.201.254 30 60 enabled disabled
VIDEO_CAM_IP_A 172.16.202.254 172.16.202.254 30 60 enabled disabled
Loopback0 192.168.100.99 192.168.100.99 30 60 enabled disabled

And I don't see route regading the PIM ....

-> show ip pim sgroute | head -n 14

Legend: Flags: D = Dense, S = Sparse, s = SSM Group,
L = Local, R = RPT, T = SPT, F = Register,
P = Pruned, O = Originator

Total 0 (S,G)

Source Address Group Address RPF Interface Upstream Neighbor UpTime Flags
---------------+---------------+--------------------------------+-----------------+--------------+--------

-> show ip pim groute | head

Total 0 (*,G)

Group Address RP Address RPF Interface Upstream Neighbor UpTime Mode
---------------+---------------+--------------------------------+-----------------+--------------+------

What could be the problem ?
We try on 6450 tu configure multicast on vlan => same result

thlks for your help.
silvio
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 1623
Joined: 01 Jul 2008 10:51
Location: Germany

Re: PIM routing pb

Post by silvio »

With PIM-SM you need to configure a bootstrap router (bsr).
f.e. ip pim cbsr 192.168.100.99

I prefere to use DVMRP instead of PIM if I have only local mc routing.
best regards
Silvio
Alcaineo
Member
Posts: 2
Joined: 28 Oct 2021 08:22

Re: PIM routing pb

Post by Alcaineo »

Hi,
After some tests and modification on the config it's working now with PIM-SM.
thks for your reply
Post Reply

Return to “OmniSwitch 6900”